Schrift im Browser auf manchen Webseiten plötzlich FETT – Lösungsweg

Heute Morgen den PC hochgefahren, wie immer. Browser gestartet, wie immer. Bei mir gehen dann gleich mehrere Tabs auf, wie immer. Ich klick mich da so durch und als ich den Facebook Tab klicke, springt mich das alles in FETTschrift an. Na nu, hat Facebook da etwas geändert, dachte ich? Andere Tabs angeschaut, dort ist alles normal.

Via Twitter gefragt, ob das evtl. auch bei anderen so ist. Natürlich nicht. Bekam dann auch einige Tipps: PC neu starten (ja ja, klingt immer albern, hilft aber doch bei dem ein oder anderen Problem), Erweiterungen im Chrome deaktivieren, Chrome neuinstallieren… Alles nix gebracht. Enno schickte mir dann noch einen Link in welchen die erneute Installation von 2 Schriftarten Abhilfe schafte. Half bei mir jedoch auch nix.

Dann ne Runde herumgegoogelt, dies und das probiert. Zwischendurch verzweifelt. Weiter herumprobiert. Weiter verzweifelt. Nix half. Im Firefox war alles normal. Im Chrome bei manchen Webseiten ja, bei anderen nicht. Bei Tweetdeck z.B. war die Timeline normal, wenn ich ein Profil öffnete war die Bio dort fett. Ominös, alles sehr ominös.

Bei dem viele herumgegoogeln kam mir dieser Thread unter, wo auch einiges probiert wurde, am Ende diese Antwort weitergeholfen hat. Seltsamerweise konnte ich nicht „Schriftart neu installieren“ wählen, warum weiss ich auch nicht. Habe aber zu einem kleinen „Trick“ gegriffen. Die Lösung:

  • Schriftartenordner geöffnet
  • alle Schriftarten markiert (STRG+A)
  • rechte Maustaste -> kopieren (oder STRG+C)
  • neuen Ordner irgendwo auf dem System erstellt
  • rechte Maustaste -> einfügen (oder STRG+V)
  • nun dürften alle im neuen Ordner eingefügt und auch noch markiert sein
  • rechte Maustaste -> installieren
  • Abfrage, ob bestehende Schriftarten ersetzt werden sollen -> JA
  • Neustart PC
  • alles wieder fein \o/

Warum dieses Problem auftrat? Keine Ahnung. Ich hatte am Vortag die Programmliste etwas aufgeräumt und u.a. itunes und einige Apple Software Dinge deinstalliert. Ob es damit zu tun hat weiss ich nicht. Aber da im oben verlinkten Forenbeitrag auch eine Deinstallation vorausging, könnte das schon eine Ursache gewesen sein.

Puh, mir geht es jetzt gleich viel besser und beim nächsten Mal, wenn dies auftreten sollte, weiss ich auch genau, wo ich nach der Lösung suche. ;)

Mein System: Windows 7 SP1, 64bit, Fehler trat in Chrome Version 37.0.2062.103 m auf

Danke an Thomas, Enno und MobiTigger fürs helfen. <3


Steve Rueckwardt

Veröffentlicht von

steve-r.de

I'm Steve and you are on my blog steve-r.de and I'm the author of this article. More about me you will find on the about me page, on Google+ or on my XING-Profile. You can also follow me on Twitter @SteveRueck and Instagram.

51 Kommentare Schreibe einen Kommentar

    • Steve Rueckwardt

      An anderer Stelle erhielt ich die Rückmeldung, mit der Chrome-Erweiterung „facebook font changer“ oder einer entsprechenden anderen Erweiterung hätte man das Problem lösen können. Damit ist zwar die Ursache irgendwie noch nicht beseitigt, aber zumindest soll die Darstellung dann wieder funktional sein.

      Ich bin verblüfft, wieviele Personen offenbar doch von diesem Problem betroffen sind. Dabei dachte ich heute Morgen noch, dies passiert nur bei mir. :)

    • Auch bei mir hat es leider nicht geklappt. Bisher kommt es bei mir nur auf Facebook unter Chrome vor. Das „Problem“ habe ich erst seit gestern, aber ich habe in letzter Zeit nichts gelöscht oder deinstalliert. Dein Tipp mit der Neuinstallation der Schriftarten hat bei mir leider nicht geholfen. :(

  1. habe erst Deinen Trick probiert – hat nicht geholfen, jetzt habe ich alle Schriftarten doppelt im Ordner – einmal mit „_0“ im Dateinamen.

    Aber hab dann doch noch die Lösung gefunden:

    Auf Facebook (bei mir war es auch auf ebay) wird für die Fonts angegeben „Helvetica, Arial, …“

    Bei meinen Schriftarten war nur eine Helvetica Bold – woher auch immer die gekommen ist, muss ja im Laufe der letzten 24 Stunden passiert sein, habe da aber eigentlich nix installiert außer nem Update vom owncloud-Client.

    Habe die Helvetica fett über Systemsteuerung|Schriftarten deinstalliert – nun ist alles wieder schick.

    Grüße von einem ebenfalls Systemadministrator :-)

    • Danke, Stephan!
      Nachdem gefühlte 10000 gegoogelte Tipps (inkl. chrome://flags) nichts gebracht haben, war die Deinstallation der „Helvetica fett“ tatsächlich die Lösung!
      Kann mir nicht vorstellen, dass diese Font irgendwie „neu“ hinzu gekommen sein sollte – habe nichts installiert. Allerdings kann ich das nicht 100%ig nachvollziehen, da ich berufsbedingt schon immer sämtliche Helvetica Schriftschnitte auf meinem System installiert habe.

      So ganz grundsätzlich: ein Helvetica Bug ist ein teurer Spaß… Ärgerlich, falls die Font überhaupt die Ursache ist. > unwahrscheinlich…

    • Bei mir war es das selbe Problem! Die Helvetica Bold hatte ich selber installiert, hatte allerdings keine normale Helvetica installiert. Deshalb macht deine Erklärung Sinn.
      DirectWrite bei Chrome brachte auch das richtige Ergebnis, nur wird dadurch natürlich nicht die Ursache behoben.
      Vielen Dank euch allen!

  2. Hallo,

    auch bei mir sah Facebook plötzlich furchtbar aus.
    Ich habe den Trick mit dem Löschen von Helvetica fett ausprobiert und schon sah alles in Facebook wieder normal aus.

    Vielen Dank für den Tipp!

  3. Bei mir hat auch folgendes geholfen…

    chrome://flags -> DirectWrite aktivieren -> Chrome neugestartet

    Problem ist gestern mit der neusten Version von Chrome entstanden. Nur auf Facebook.

  4. Das ist wirklich die Lösung und Facebook zeigt das gewohnte Bild:

    chrome://flags -> DirectWrite aktivieren -> Chrome neugestartet

    Allerdings wird mit dem Befehl „aktivieren“ DirectWrite DEaktiviert und umgekehrt. Interessant ist, dass IE11 die gleichen Probleme mit der Facebook-Schrift hat, FF35 dagegen nicht, nutzt wohl kein DirectWrite, wie Chrome ab 37.

  5. So – jetzt habe ich auch den Verursacher gefunden.

    beim Starten von Lexware Quicken 2015 wird eine Installation durchgeführt, die die Schriftart Helvetica Fett installiert.

    Wenn sie fehlt, soll diese Installation wieder beim Neustart wieder ausgeführt werden und das Programm lässt sich nicht starten ohne die Installation durchzuführen.

    Ich werde also eine Anfrage beim Lexware Support stellen, was es damit auf sich hat.

    Grüße
    Stephan

    • Ich installiere sie ja – aber es geht mir neben der Lösung des Problems, die ich mit dem DirectWrite durchführen könnte, darum, den Müll den Quicken da produziert zu verhindern.

      Wenn dann müssten sie auch Helvetica normal installieren oder die unnötige Installation verhindern.

      :-)

      Grüße
      Stephan

    • Steve Rueckwardt

      Na na, wieso denn Quicken? Eine Schriftart zu installieren ist ja an sich nix ungewöhnliches und schlimm auch nicht. Das machen viele Programme, wo es halt notwendig ist. Warum es Quicken unbedingt braucht? Keine Ahnung. Aber dass es nicht alleinig an Quicken oder auch dieser speziellen Schriftart liegen kann, zeigt die Häufigkeit dieser Vorfälle. Dabei dachte ich eigtl. bei Erstellung des Artikels, ich hätte das was ungewöhnliches und seltenes.

      Ich vermute eher, es hängt mit einem Update bei Chrome zusammen, was ja im Hintergrund abläuft. Dies würde die Häufigkeit erklären. Quicken oder eine bestimmte Schriftart hat damit eher nix zu tun. Davon ab ist Helvetica eine gebräuchliche Schriftart, welche schon vor Quicken da gewesen sein dürfte, Quicken eben nur muckt, wenn Du sie dann deinstallierst. (warum auch immer)

    • Helvetica ist eine Kaufschriftart, die nicht Standardmäßig installiert ist, wenn Helvetica normal auch installiert werden würde, wäre es auch kein Problem…
      Websites definieren nun mal Fonts die genutzt werden sollen. Eine übliche Form ist „Helvetica, Arial,Sans-serif“.
      Wenn nun auf einem Rechner Helvetica installiert wird (sowohl normal als auch fett) ist alles gut – wenn, wie in diesem Fall nur Fett installiert wird, kommt es zu dem Problem. Ich werde mir das mit dem DirectWrite mal anschauen und melde mich dann wieder.

    • Steve Rueckwardt

      Wenn dem so ist (bzgl. Kauf oder Nicht-Kauf kann ich nicht beurteilen – da ich diese Schriftart aber nahezu überall auf Kunden-PCs antreffe, wird sie vermutlich durch Standardprogramme wie z.B. Word o.ä. auf de PCs landen), warum tritt das Problem denn dann plötzlich auf? Denn wenn ich Deine Schilderung richtig verstanden habe, so war bei Dir ja bisher nur Helvetica Bold vorhanden, richtig? Die Häufigkeit der Fälle lässt für mich bisher eher den Schluss zu, dass eine Änderung welche übergreifend bei unterschiedlichen Nutzern der Fall war, dafür ursächlich ist. Ein Chrome-Update würde aus meiner Sicht hier hineinzählen.

      Ich kann nicht beurteilen, ob vor meiner „Lösung“ Helvetica NUR in Bold da war. Da ich aber alle bestehenden Schriftarten neu installiert habe (wie oben beschrieben) dürfte ja nun nicht mehr da sein, als vorher. :) Bei mir gibt es aber alle möglichen Arten von Helvetica (fett, fett schräg, halb schmal, halb schmal fett, halb schmal fett schräg, halb schmal schräg, schmal, schmal fett, schmal fett schräg, schmal schräg, schräg, standard).

    • Also … chrome://flags hat bei mir nicht geholfen.

      Nochmal zu Helvetica:
      Diese Schriftart wird nicht durch Standard-Anwendungen installiert.
      Die kostenfreie Windows-Version von Helvetica ist Arial.
      Helvetica muss man kaufen – oder es kommt mit einer Anwendung mit.
      Umsomehr irritiert das auch von anderen Usern bei Lexware gemeldete Verhalten von Quicken, dass aber ja scheinbar nicht bei jedem auftritt.

      Es bleibt mir also nur, zu warten, bis Lexware reagiert.

    • Steve Rueckwardt

      Ganz ehrlich: was soll da Lexware reagieren bzw. was genau erwartest Du? Das Problem tritt ja offenbar auch bei Nutzern auf, die nix von Lexware aufm PC haben. Und selbst wenn: es lief „normal“ und am nächsten Tag nicht mehr. Also hat sich doch eher etwas am PC bzw. Browser geändert, meinste nicht?

    • Nein, meine ich nicht.

      Wenn eine Anwendung eine Schriftart, die sie soweit erkennbar nicht verwendet installieren möchte, und nachdem sie deinstalliert wurde, wieder installieren will und sich nicht starten lässt ohne die Installation abzuschließen und das ab einem tag x und eben nur einen schriftschnitt dieser Schrift installiert (und genau das ist ja das Problem) dann sehe ich dieses Problem bei einer Änderung in dieser Anwendung.

      Und wie gesagt – das mit DirectWrite funktioniert bei mir nicht.

    • Steve Rueckwardt

      Nur ist eben das nicht das Kernproblem. Denn wie erwähnt: ich habe alle Schriftartbestandteile. Andere haben kein Quicken. Dennoch tritt das Problem (gar nicht so selten wie ich dachte) auf. SiBu schreibt ja, dass bei ihm Quicken problemlos läuft, auch ohne Helvetica Bold.

      Was soll also Lexware Deiner Ansicht nach in diesem Sachverhalt tun?

    • Sie sollen das Problem nicht global lösen, aber mir erklären, warum ich Quicken nicht starten kann ohne diese Installation. Damit wäre für mich das Problem gelöst.

  6. Ich habe jetzt mal probiert, die Schrift Helvetica Fett zu deistallieren (Schrift vorher in anderem Ordner speichern) und tatsächlich: das Problem in Facebook ist verschwunden, egal ob IE oder Chrome. Man kann sogar die Änderung (chrome://flags -> DirectWrite aktivieren) wieder rückgängig machen. Bis jetzt zeigt das Fehlen der Schrift keine Auswirkung auf Quicken 2015.

    • Keine Auswirkungen auf Quicken 2015 bei Dir? Interessant. Werde es im Lexwareforum weiter verfolgen. Dort hat jemand mit Quicken 2014 deluxe seit Mitte Juli das gleiche Problem… Es bleibt spannend.

    • @ Stephan:
      Quicken läuft bei mir ganz normal, die Schrift Helvetica Fett ist nicht mehr vorhanden und ich sehe auch keine Schriftfehler. Quicken will beim Start (auch online) nicht die Schrift installieren > Windows 8.1, 64 bit

  7. 1000 Dank, Walters Weg über directwrite hat auch bei mir geklappt! Hatte ebenfalls das Phänomen, dass einfach so plötzlich manche Schriften auf den Seiten fett waren. Super Tip!

  8. Das war jetzt wirklich der richtige Tipp. Mit dem neuen Update von Lexware Quicken fing der Ärger schon wieder an. Bei jedem Start wollte Quicken die Helvetica Bold-Datei neu installieren. Dieser Link war goldwert!

  9. Gleiches Schriftproblem tritt auch bei Opera 12 auf,obwohl ich kein Lexware Quicken usw. habe.Habe meist die t-online Startseite am Anfang und meißt bei e-bay dannach trat die neue Schrift auf.Habe dann alle Cookies und Speicher für Webseiten gelöscht und AVG PC Tuneup
    alle temp .Dateien und Windows Verlauf löschen lassen.Dann ging alles wieder, bis man mal wieder bei t-online surft.Irgendwas wird einen hier untergejubelt,nur bin ich bis jetzt noch nicht dahintergekommen.AVG findet jedenfalls nichts.es hängt aber definitiv mit den vom Browser gespeicherten Cookies oder anderen vom Browser aufgezeichneten Sachen zusammen.Ich logge mich auch bei veränderter Schrift nirgendwo ein,bis der Verursacher entdeckt ist.Die störende Schrift einfach zu löschen ist aber bestimmt nicht die optimale Lösung.

  10. Hatte auch den Fehler bei Opera das alle Schriften Fett angezeigt war doch leider hat diese Methode bei mir nicht geklappt, aber dann habe ich es selber Herausgefunden in den ich die Schrift von Webbrowser kopiert habe, und in das Microsoft Word eingefügt um zu schauen welche Schriftart es bei mir ist es war „Helvetica Black“ anschließend habe ich bei dem Windows Fonts genau diese Schriftart dann gelöscht und Bingo! =) Nun ist alles wieder normal, ich hoffe ich konnte auch helfen wenn einer mein Problem hat, das selbe geht dann natürlich auch mit anderen Schriftarten also erst kopieren und schauen um welche Schriftart es sich handelt.

    Mit freundlichen Grüßen
    Tobi-it

  11. Habe diesen Blog nach Suche über Google gefunden. Ist ja leider schon älter.

    1. finde ich den „DirectWrite“-Eintrag bei chrome://flags/ nicht. Ist das inzwischen raus genommen worden oder umbenannt?

    2. Nach durchlesen der Kommentare habe ich nun auch Helvetica Fett deinstalliert und hat mein Problem zu 100% gelöst. Bin mir aber nicht bewusst das ich die letzten Tage etwas installiert oder deinstalliert habe – außer das standardmäßige Chrome-Update.

    FB funktioniert wieder und auch die Foren in denen ich unterwegs bin.

  12. Helvetica Fett wird z.b. durch Quicken (Lexware) automatisch immer neu Installiert, wenn es Fehlt. Mann kann aber über eine Konsole ( mit Administratorrechten starten) in dem ordner dann einfach eine Andere Schriftart drüberkopieren ( z.B.
    copy arial.ttf HEB_____.TTF ).Dann ist die Schrift füe Lexware vorhanden und installiert sie nicht neu :-)

Schreibe einen Kommentar